eu-srv-1/configuration.nix

56 lines
1.8 KiB
Nix

# Edit this configuration file to define what should be installed on
# your system. Help is available in the configuration.nix(5) man page
# and in the NixOS manual (accessible by running `nixos-help`).
{ ... }:
{
imports =
[ # Include the results of the hardware scan.
./hardware-configuration.nix
./common
./common/server
./common/users/scott
./services
];
boot.loader = {
# Use the GRUB 2 boot loader.
grub = {
enable = true;
efiSupport = true;
efiInstallAsRemovable = true;
# Define on which hard drive you want to install Grub.
device = "/dev/sda"; # or "nodev" for efi only
};
efi.efiSysMountPoint = "/boot/efi";
};
networking = {
hostName = "eu-srv-1"; # Define your hostname.
};
# Pick only one of the below networking options.
# networking.wireless.enable = true; # Enables wireless support via wpa_supplicant.
# networking.networkmanager.enable = true; # Easiest to use and most distros use this by default.
# Set your time zone.
time.timeZone = "UTC";
# Configure network proxy if necessary
# networking.proxy.default = "http://user:password@proxy:port/";
# networking.proxy.noProxy = "127.0.0.1,localhost,internal.domain";
# Select internationalisation properties.
i18n.defaultLocale = "en_US.UTF-8";
# This value determines the NixOS release from which the default
# settings for stateful data, like file locations and database versions
# on your system were taken. It's perfectly fine and recommended to leave
# this value at the release version of the first install of this system.
# Before changing this value read the documentation for this option
# (e.g. man configuration.nix or on https://nixos.org/nixos/options.html).
system.stateVersion = "23.05"; # Did you read the comment?
}