a9a36793ad
This PR introduces a Nix flake, allowing for InfiniTime to be built as a
Flake, including a FHS development environment.
It's derived from #1850 and
c57c57f3c6
.
We also introduce `flake-compat`, allowing for non-Flake Nix mahcines to
use the project as-is, both for building (`default.nix`), and
development (`shell.nix`).
Additionally, we introduce `.envrc`, meaning that with `direnv`, the Nix
Flake is activated automatically.
Fixes #1850.
Signed-off-by: Dom Rodriguez <shymega@shymega.org.uk>
11 lines
343 B
Nix
11 lines
343 B
Nix
(import
|
|
(
|
|
let lock = builtins.fromJSON (builtins.readFile ./flake.lock); in
|
|
fetchTarball {
|
|
url = lock.nodes.flake-compat.locked.url or "https://github.com/edolstra/flake-compat/archive/${lock.nodes.flake-compat.locked.rev}.tar.gz";
|
|
sha256 = lock.nodes.flake-compat.locked.narHash;
|
|
}
|
|
)
|
|
{ src = ./.; }
|
|
).defaultNix
|